Suspension problem

Post Reply
Rawbad
Enlisted
Posts: 1
Joined: Wed Jul 10, 2019 9:34 am

Suspension problem

Post by Rawbad » Wed Jul 10, 2019 9:53 am

Good day guys,

I am Robert driving a POLO TSI 2014, I went for wheel alignment on the previous passed Sunday (07/7/2019) but still the problem continues. when I drive even after wheel alignment it drives off the road by turning itself towards the driver's side (right hand side), the car doesn't drive straight, I cant drive the speed of 100 because it may over turn and it wants me to always hold the steering wheel. The minute I leave the steering wheel the car drives off road immediately turning right towards the driver's side. even when I turn to right on the driver's side there is a funny sound as if the wheel is touching something making a sound that is not comfortable. I am in Pretoria please refer me to someone that can really understand & know how to fix the problem, because the guys that did the wheel alignment told it is the suspension. it only makes the sound when I turn right on the driver's side. Please assist & thanks in advance....
Supervan II
Cadet
Posts: 802
Joined: Thu Aug 04, 2005 9:26 pm
Car Make: SEAT
Membership No: missing
Location: Port Elizabeth

Re: Suspension problem

Post by Supervan II » Wed Jul 10, 2019 7:42 pm

Have you tried swopping your front tyres from L to R? (Unless they are uni-directional, of course, else put your RR to RF.)

If this does not solve your problem, then it's either your steering rack that's shot or your RHS tie-rod end unless the car hit a pavement/pothole recently and suffered some serious damage (measure the distance between wheel and rear of fender on both sides for comparison).
User avatar
Sean Trollope
Cadet
Posts: 303
Joined: Fri Oct 27, 2017 4:01 pm
Car Make: VW. Hyundai.
Car Model: Citi golf. Hyundai i10

Re: Suspension problem

Post by Sean Trollope » Wed Jul 10, 2019 7:44 pm

Also check tire pressures.

Sent from my SM-G570F using Tapatalk

Post Reply