weird glow plug flashing

Post Reply
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

weird glow plug flashing

Post by [email protected] » Sun Jun 10, 2018 6:42 pm

ok after today cleaned my airbox and drain oil catch tank normal thing i do i start car and all good. next morning car struggles to start and cut of and then didn't wane start. so searched online and guys say brake lights or brake switch so removed all and 're inserted again car starts but glow plug light flashes this also flashes when car started this morning when died. car starts now but glow plug light keeps flashing so presume brake light switch maybe? or maybe 1 glow plug?

just weird because previous day was 100 morning this symptoms happen.

just to mention also my main light switch broke so can this also cause maybe false alarm to the brake light switch and cause glow plug to come on?

Sent from my SM-G950F using Tapatalk

User avatar
vee4410
Cadet
Posts: 236
Joined: Sun Oct 25, 2015 7:18 am
Car Make: VW
Car Model: Polo 9n3 1.9 TDI, 9n 1.6
Location: Durban

Re: weird glow plug flashing

Post by vee4410 » Sun Jun 10, 2018 8:36 pm

Best to get the car scanned to find any error codes. It is possible that the faulty switch can cause the glow plug light to come on. Does the engine idle as normal before it dies?
Current Rides:
2007 Polo 9n3 1.9 TDI
2004 Polo 9n 1.6
2015 MB w205 C180
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Mon Jun 11, 2018 7:31 am

car seems to idle fine yes will be driving it today just to see if its maybe a glow plug or not and do an resistance test on the plugs

Sent from my SM-G950F using Tapatalk

User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Mon Jun 11, 2018 11:09 am

glow plug flashing can be one of 100's of faults - used to tell you there is a warning type fault on the motor somewhere instead of switching the engine light on. Get it scanned and you'll see some error - could relate to boost or several others. Not just an actual glowplug issue.
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Mon Jun 11, 2018 1:12 pm

thanks panic. was going to do that also. car starts but just now didn't want swing again. and now its dead just swings but ya.

Sent from my SM-G950F using Tapatalk

User avatar
vee4410
Cadet
Posts: 236
Joined: Sun Oct 25, 2015 7:18 am
Car Make: VW
Car Model: Polo 9n3 1.9 TDI, 9n 1.6
Location: Durban

Re: weird glow plug flashing

Post by vee4410 » Mon Jun 11, 2018 2:29 pm

Also check your earth strap and connections at the starter/on top of battery.
Current Rides:
2007 Polo 9n3 1.9 TDI
2004 Polo 9n 1.6
2015 MB w205 C180
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Mon Jun 11, 2018 4:22 pm

well found one problem harness is completely screwed and brittle already and never saw this only now. but might have also damaged one of the glow plugs also in long run. seems the lady had before me fuckt it up good.

see photosImageImageImage

Sent from my SM-G950F using Tapatalk

User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Mon Jun 11, 2018 6:49 pm

Broken glow plug harnass is a common thing. Does not mean anybody before did not care about the car. They are subject to a lot of heat.
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Mon Jun 11, 2018 7:07 pm

yes correct but this was broken off can see where it was forced down on the plastic so this is definitely been taken of the wrong way or very brutally. just as other stuff on the car which i had to replace due to people not taking care of they cars. but ya heat is bad on plastic but not like that which was forced and broken.

but anyway one problem found still need to diagnostic it and see if any other problems also.

Sent from my SM-G950F using Tapatalk

User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Thu Jun 14, 2018 8:10 am

ok another update tried to connect to diagnostic port and read ecu just gives error used 4 different devices and brands. all error also found why car gives problems starting and then drives my crank sensor wire seems to be faulty as soon touch it car shuts off and if move it a bit car starts. so replacing that today. but still weird why can't connect to ecu suddenly

Sent from my SM-G950F using Tapatalk

User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Fri Jun 15, 2018 6:15 am

Check the diagnostic port's wiring at the ecu. Also one of the points should have a voltage on it. - see that it is there.

Pin 16. https://mechanics.stackexchange.com/que ... n-ignition
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Fri Jun 15, 2018 6:47 am

hey already checked for voltage at point 16 and there is voltage. we just can't find the same wire colour on the ecu harness side. i even got diagrams from vw but still cant see pin 16 on the ecu side point do u know if the colour changes to that side perhapa panic or what point to measure on the ecu side ? or i presume point 16 is going to battery?

yesterday when i braked hard and car slid a bit suddenly the glow plug light goes away and also engine light but still cant read ecu.

Sent from my SM-G950F using Tapatalk


Last edited by [email protected] on Fri Jun 15, 2018 6:47 am, edited 1 time in total.
User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Fri Jun 15, 2018 6:49 am

if there is power then the wire colour does not matter.
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
175SBU
Cadet
Posts: 407
Joined: Sun Sep 20, 2015 7:25 pm
Car Model: MK1 1.4i, MK2 CSi
Location: Johannesburg

Re: weird glow plug flashing

Post by 175SBU » Fri Jun 15, 2018 6:57 am

panic-mechanic wrote:Check the diagnostic port's wiring at the ecu. Also one of the points should have a voltage on it. - see that it is there.

Pin 16. https://mechanics.stackexchange.com/que ... n-ignition
Helpful information, dankieImage


Sent from my iPhone using Tapatalk
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Fri Jun 15, 2018 7:03 am

this is what i used from vw to check out pins and cross checking but can't find problem unless there is a break in harness somewhere ImageImage

Sent from my SM-G950F using Tapatalk

User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Fri Jun 15, 2018 7:48 am

If you had a break in the harnass then you won't be able to get continuity. Can you speak to other modules but not the engine or nothing at all?
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Fri Jun 15, 2018 7:51 am

hey i can't speak to anything yes. diagnostic interface goes in but once u wane connect then throws u an error can't connect to on-board computer or ecu.

Sent from my SM-G950F using Tapatalk

User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Fri Jun 15, 2018 7:56 am

Then a issue maybe with the canbus controller
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Fri Jun 15, 2018 7:58 am

well how to figure that out then. anynway testing this panic

Sent from my SM-G950F using Tapatalk

User avatar
panic-mechanic
Panic's Place
Posts: 25239
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.

Re: weird glow plug flashing

Post by panic-mechanic » Fri Jun 15, 2018 8:07 am

I really never had to fix a comms problem other than having found a broken wire. Maybe try Dr GOOGLE and see if anybody else had that and found a solution. Sorry can't be more helpfull - just never had to fix such an issue.
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'09 Audi Q5 3l tdi
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.
User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Fri Jun 15, 2018 8:09 am

not a problem thanks

Sent from my SM-G950F using Tapatalk

User avatar
[email protected]
Cadet
Posts: 75
Joined: Thu Nov 10, 2016 7:43 pm
Location: Bellville

Re: weird glow plug flashing

Post by [email protected] » Thu Jun 21, 2018 6:21 pm

seems the crank sensor is faulty or had short and causes me not to be able to connect to ecu once unplug and tried to connect again worked then plug in and no connection. weird but ya that is the cause. replacing sensor weekend.

Sent from my SM-G950F using Tapatalk

Post Reply