Need help - mp9 wiring

User avatar
scroodrv
Cadet
Posts: 326
Joined: Mon Nov 06, 2006 12:22 pm
Location: CT
Contact:

Need help - mp9 wiring

Postby scroodrv » Mon Mar 01, 2010 4:00 pm

Hey Guys, we bought this 1.8 motor complete with mp9 loom and ecu. Dropped the motor in on saturday, all went ok. Got onto the wiring loom and encounted a few problems. The red crosses indicate what is not obviously visible on the loom

Image

Have fitted all the wires with the nice VW connectors on, they are easy..

These are the wires I have left:
Image
1. The red one is a small gauge wire, could reach starter motor but looks very skinny? not sure where this one will go.
Image
yellow wire with red stripe? Not sure, we dont have an air temp wire, so could be that?
Image
The black and yellow Im thinking is the power, power only when ignition is on. Green wire I think goes to pin no. 6 on the TCI unit?
Image
This pic is of the ecu connector, just for info to help someone whos know the loom identify the rouge wires

The only ground on the had a circular crimp so we connected it to the cylinder head, hope thats ok?
TIA

just notice something different on the top pic - where i put the red cross over the temp sensor wire, the loom we have, has the vw connector on it, not a single wire...
Subaru Sti
Polo TDI sportline PD130(STO tuned & decat) (for sale)
Cti 8V 1.8t (sold)
My Rides thread

UDC
Colonel
Posts: 5498
Joined: Tue Jan 09, 2007 9:45 am
Membership No: 1041
Location: Durban
Contact:

Re: Need help - mp9 wiring

Postby UDC » Mon Mar 01, 2010 4:18 pm

that yellow/red should be going to the water temp gauge, is it running of the 4 pin water temp plug?
the green looks like the rev counter signal.
the red could be for your oil pressure, you need to back trace it, normally its a blue wire
nothing from the mp9 harness goes to the starter.

User avatar
scroodrv
Cadet
Posts: 326
Joined: Mon Nov 06, 2006 12:22 pm
Location: CT
Contact:

Re: Need help - mp9 wiring

Postby scroodrv » Mon Mar 01, 2010 4:36 pm

will test the yellow/red with the multimeter but i think you right, its the temp signal for the dash
The green may well go to the rev counter, but then what connects to the TCI unit?
will trace back the red and see which pin it goes to on the ecu
Subaru Sti
Polo TDI sportline PD130(STO tuned & decat) (for sale)
Cti 8V 1.8t (sold)
My Rides thread

User avatar
panic-mechanic
Panic's Place
Posts: 24035
Joined: Mon Jul 29, 2002 9:08 am
Membership No: 79
Location: Benoni, putfontein.
Contact:

Re: Need help - mp9 wiring

Postby panic-mechanic » Mon Mar 01, 2010 6:02 pm

Unless they use the red as a power wire for a relay and then the big starter will always supply 12v. Exactly the same as battery +
Stephan van Tonder - Jhb - Putfontein Benoni
'07 Audi S6 V10 - beast !!!!!
'05 Audi A6 3.0L TDI Avant
'07 Audi A4 2l TDI
'95 Audi 90 coupe quattro
'13 VW CC 2l tdi (repair project)
'05 Touareg v10

Perfect Power dealer. I do dyno tuning.

User avatar
scroodrv
Cadet
Posts: 326
Joined: Mon Nov 06, 2006 12:22 pm
Location: CT
Contact:

Re: Need help - mp9 wiring

Postby scroodrv » Tue Mar 02, 2010 8:12 am

there is no red big wire going to the starter, just the small gauge red wire. Could it be the low current side of the fuel pump relay? Then I must install the high current side and relay. If I power up the ecu and test it with a multimeter and it shows 12V+ can I assume its the fuel pump relay?

FYI: this loom was originally doctored for a CTI converted to MP9. This project im trying to change from 1.3 carb citi golf to 1.8i
Subaru Sti
Polo TDI sportline PD130(STO tuned & decat) (for sale)
Cti 8V 1.8t (sold)
My Rides thread

Return to “General Tech Discussions”

Who is online

Users browsing this forum: No registered users and 79 guests