2007 citi golf 1.4i mp9

Post Reply
Jaylee
Enlisted
Posts: 2
Joined: Thu Mar 26, 2020 2:50 pm

2007 citi golf 1.4i mp9

Post by Jaylee »

I have a 2007 citi golf 1.4i mp9, in the mornings after a few minutes of starting the car it picks up a mis, the fuel pump starts making a loud noise and when driving uphill it feels as though it's starving for fuel, I have done diagnostics the guy said everything is in order he suspected the fuel tank, I took the tank off it did feel as though it was jammed so we got it cleaned up and put it back, it was fine for a day and went back to the same issue the next day, pls help guys I'm so stressed I can't fine the fault and don't want to invest in a tank for no reason if it's not that :sad:

User avatar
Jetta2
Field Marshal
Posts: 14556
Joined: Sun Dec 10, 2006 12:32 am
Car Make: VW, VW, Aprilia
Car Model: VR6, Caddy, RSV4
Membership No: 1087
Location: Menlo Park, Pretoria

Re: 2007 citi golf 1.4i mp9

Post by Jetta2 »

Did the person who did the "diagnostics" check the fuel pump pickup in the tank to see if the filter was clean?
Did he check the actual fuel pressure?
Was the fuel filter checked/replaced?

Also check the fuel rail, they are known to break internally. Clamp the fuel return closed and see if the miss disappears. If it does, there is a 99% chance the fuel rail is FUBAR.
Replace it with a new one.

Take the fuel rail off and shake it. If it makes a noise, then you know who the culprit is.
Ryan Demoser

1996 Mk3 Golf VR6
2017 Caddy Maxi Crew Bus 2.0 TDI
2013 Aprilia RSV4 track toy

Jaylee
Enlisted
Posts: 2
Joined: Thu Mar 26, 2020 2:50 pm

Re: 2007 citi golf 1.4i mp9

Post by Jaylee »

We tested 2 rails its doing the same thing

Post Reply