Citi Golf - Indicators not working....

Post Reply
Howie-WP
VWCSA Member
Posts: 13439
Joined: Mon Jul 29, 2002 11:45 am
Membership No: 2033
Location: Cape Town, SA

Citi Golf - Indicators not working....

Post by Howie-WP » Thu Jun 09, 2011 9:25 pm

Trying to help a girl at work's friend. She has a 2005/6 Citi 1.4 (dunno if it is carb or FI) Anyways, apparently the indicators stopped working. No hazards, seems you can hear the relay clicking but no indicators....... taken it to a auto elec (apparently) and they say it needs a new control unit?

Does this sound feasible? I heard numbers of R1.8k for this control unit..... ideas???

I am not too clued up on the new Citi's and the electrics..... :driving: :hi:
dood786
Post Whore
Posts: 19398
Joined: Thu Mar 08, 2007 10:36 am
Car Model: boat
Membership No: 1133
Location: Lenasia
Contact:

Re: Citi Golf - Indicators not working....

Post by dood786 » Thu Jun 09, 2011 9:41 pm

Fuse?
Noob
Howie-WP
VWCSA Member
Posts: 13439
Joined: Mon Jul 29, 2002 11:45 am
Membership No: 2033
Location: Cape Town, SA

Re: Citi Golf - Indicators not working....

Post by Howie-WP » Thu Jun 09, 2011 10:02 pm

dood786 wrote:Fuse?
I was thinking along the same lines, hearing 3rd hand that it was at an auto electrician, would have thought they would have checked this. Does the indicator have a relay?
GTI_786_EC
Cadet
Posts: 60
Joined: Mon May 30, 2011 8:05 am
Car Make: VW
Car Model: Polo Vivo - R
Membership No: missing
Location: Uitenhage, Port Elizabeth

Re: Citi Golf - Indicators not working....

Post by GTI_786_EC » Fri Jun 10, 2011 5:24 am

Buddy not all auto electricians are good people. No offence to anyone!
But maybe he just said its the control unit to try and milk the owner.
And people like taking advantage if its a lady driver...

So firstly, check the fuses.
Secondly, get a second opinion.
User avatar
GolfMad
Brigadier
Posts: 6598
Joined: Sun Jan 13, 2008 5:52 pm
Car Make: Nissan
Car Model: Terrano 2.7 TDi 4x4
Membership No: missing
Location: Oppie Berg

Re: Citi Golf - Indicators not working....

Post by GolfMad » Fri Jun 10, 2011 7:47 am

I HATE auto electricians as I had some serious issues with skelms myself. They tend to make up sh!t especially if they see you are not clued up, and sadly woman are often their biggest vitims.

As far as I know any citi use a normal switching relay (flicker unit) that one can buy at Midas or the like.
Current Mk3 Gti Sold.
Jy kan met 'n Nissan (soms)

VroetelTrok - 1974 VW Baywindow Bus
User avatar
SHAUN
Post Whore
Posts: 29491
Joined: Thu Jul 15, 2004 7:06 pm
Car Make: BMW
Car Model: 2006 335i
Membership No: 1148
Location: WildWest

Re: Citi Golf - Indicators not working....

Post by SHAUN » Fri Jun 10, 2011 9:15 am

The indicator relay is built into the hazard switch. They are around R500 from the dealers.
2006 E92 335i * Monica
2001 Audi S3 Quattro * Suzie-Q
1999 Jetta 3 20vt 181kw 390nm * Jet-Li
2006 Caddy 1.6 low and slow * Tossa-Caddy
2001 Polo classic 16v ABF Featured * BLUEmotion
1988 Bmw E30 2.9L - Written off
1991 MKII GTI - Sold
1989 MKII CSL - Sold
Saiendra wrote: I cannot argue with you, you bought a BMW out of motorplan...
You clearly have more balls than me.
Velorox
Cadet
Posts: 50
Joined: Fri Mar 25, 2011 11:56 am
Car Make: VW
Car Model: 2k5 VeLoCiTi 1.4i
Membership No: missing
Location: Krugersdorp

Re: Citi Golf - Indicators not working....

Post by Velorox » Fri Jun 10, 2011 10:24 am

Try those big fuses next to the battery, take them out and clean them. My friend's 2004 citi did the same last week Saturday, he went to an electrician and was told it might be a control unit. I was not available the whole of Saturday and I received so many call backs from him. I only saw him Sunday and i took them out (part of my experience) and opened one of them and it worked. If it does not work its really a control unit, mine was bridged (too expensive) coz my wipers were not working last year December. Good luck.
User avatar
booysene
Cadet
Posts: 76
Joined: Thu May 27, 2010 2:54 pm
Car Make: VW
Car Model: MK1 GLS
Membership No: missing
Location: Eastern Cape

Re: Citi Golf - Indicators not working....

Post by booysene » Fri Jun 10, 2011 11:26 am

I had the same problem, lights were showing inside but nothing on the outside. I replaced the control unit and the hazards and indicators worked same time. There is a number on the unit, write it down and take it to the nearest 2nd hand vw spares place (not agents). I paid R250
vw mk1 1981 1800i 8V
uncivilized
Enlisted
Posts: 8
Joined: Thu May 19, 2016 8:39 am
Location: durban

Re: Citi Golf - Indicators not working....

Post by uncivilized » Mon Jun 27, 2016 10:45 am

Which 2nd hand dealer did u get it from? I'm looking for a control unit and it's almost impossible to get 1
cpureaper
Enlisted
Posts: 26
Joined: Sun Oct 13, 2013 12:37 pm
Location: Uitenhage

Re: Citi Golf - Indicators not working....

Post by cpureaper » Wed Jun 29, 2016 6:32 am

Hi
Ok you don't say what year model so that does not help much.
If it of the last citi golfs then this could be the case that you will be charged this amount. The last citi golfs had a Bordnetz control unit which controls more than your indicators. But of the most problems I have had is that they pack up. And guess what is the first to go? Indicators!

Its the control unit just above your accl pedal.

To those of you out there have a look and please put a plastic bag over then. As you know citis like to get water in that area. Also turn the two relays in that area around as they get full of water and act like cups.

Cheers and hope this helps!
Morne777
Enlisted
Posts: 5
Joined: Fri Aug 11, 2017 6:13 pm

Re: Citi Golf - Indicators not working....

Post by Morne777 » Sun Aug 13, 2017 2:14 pm

Hi all

I replaced my steering wheel yesterday and now my indicators wont work...The hazards work perfect i also checked the fuses all in tact...did i short it somewhere?

Its a 1990 1300
BMW 540 E39 2001
City golf 1300 1990(feels like a 1800)
User avatar
Neuk
Treasurer
Treasurer
Posts: 48491
Joined: Mon Nov 28, 2005 2:58 pm
Car Make: VW
Car Model: '15 Golf R
Membership No: 806
Location: Johannesburg

Re: Citi Golf - Indicators not working....

Post by Neuk » Mon Aug 14, 2017 7:51 am

Image
Nic

Current Garage:
Daily Drive: 2015 VW Golf R
Project Fes: 1982 VW Golf GLS 1.5
Project FeO: 1966 VW Type 2 Transporter Kombi Split Window

Previous Garage:
Vagon: 2005 Audi B6 A4 1.8T (140kw) Avant
Project XXXX: 1967 VW Type 3 Variant (Squareback)
Project Betty: 2005 Polo 1.9 TDI (PD130) Sportline
Weekend Warrior: 1993 Volkswagen Caddy 2.0 16v ABF on ITB's
Howie-WP
VWCSA Member
Posts: 13439
Joined: Mon Jul 29, 2002 11:45 am
Membership No: 2033
Location: Cape Town, SA

Re: Citi Golf - Indicators not working....

Post by Howie-WP » Wed Aug 16, 2017 10:17 pm

Morne777 wrote:Hi all

I replaced my steering wheel yesterday and now my indicators wont work...The hazards work perfect i also checked the fuses all in tact...did i short it somewhere?

Its a 1990 1300
When changing the steering wheel, did you perhaps mistakenly removed the indicator stalk?? :oops:
[email protected]
Enlisted
Posts: 2
Joined: Fri Apr 20, 2018 1:31 pm
Car Make: VW
Car Model: Mk 1 Caddy

Re: Citi Golf - Indicators not working....

Post by [email protected] » Fri Apr 20, 2018 1:46 pm

Where can I get a good Wiring Diagram for a 1995 VW Caddy?
95' Caddy 2,0 8v
User avatar
Neuk
Treasurer
Treasurer
Posts: 48491
Joined: Mon Nov 28, 2005 2:58 pm
Car Make: VW
Car Model: '15 Golf R
Membership No: 806
Location: Johannesburg

Re: Citi Golf - Indicators not working....

Post by Neuk » Fri Apr 20, 2018 2:02 pm

[email protected] wrote:
Fri Apr 20, 2018 1:46 pm
Where can I get a good Wiring Diagram for a 1995 VW Caddy?
Haynes manual.
Nic

Current Garage:
Daily Drive: 2015 VW Golf R
Project Fes: 1982 VW Golf GLS 1.5
Project FeO: 1966 VW Type 2 Transporter Kombi Split Window

Previous Garage:
Vagon: 2005 Audi B6 A4 1.8T (140kw) Avant
Project XXXX: 1967 VW Type 3 Variant (Squareback)
Project Betty: 2005 Polo 1.9 TDI (PD130) Sportline
Weekend Warrior: 1993 Volkswagen Caddy 2.0 16v ABF on ITB's
[email protected]
Enlisted
Posts: 2
Joined: Fri Apr 20, 2018 1:31 pm
Car Make: VW
Car Model: Mk 1 Caddy

Re: Citi Golf - Indicators not working....

Post by [email protected] » Fri Apr 20, 2018 2:09 pm

Thank you.
I will try the Haynes Website.
95' Caddy 2,0 8v
Post Reply