Help Please - Steering,ABS and handbrake light and warning l

Xploding-TDi
Cadet
Posts: 62
Joined: Sun Feb 23, 2014 5:43 pm
Location: South Africa

Re: Help Please - Steering,ABS and handbrake light and warni

Post by Xploding-TDi » Tue Nov 25, 2014 2:12 pm

Torker wrote:I've seen a couple of cases where a cracked (not blown) fuse on top of the battery caused warning lights and heavy steering in 9N3 Polo's.
I'm going to try amd replace them all soon.
User avatar
g60 golf
Moderator
Posts: 3993
Joined: Tue Jul 18, 2006 6:51 pm
Membership No: 388
Location: jhb

Re: Help Please - Steering,ABS and handbrake light and warni

Post by g60 golf » Tue Nov 25, 2014 9:37 pm

I agree a bearing will cause issues with speedo but not reseting the speedo ie the trip meter.
the bearings also csuse the abs and traction to activste at low speeds.
G60 16V GOLF

WHAT WE LEAVE BEHIND IS NOT AS IMPORTANT AS HOW WE LIVED.

IT IS NOT UNSAFE IT IS OLD SCHOOL!!!!!!!!!

ALDO IS THE MAN WITH A GUN.
THATS HOW WE ROLL [SAINT-J]
GTS KNOWS HOW TO MAKE A STICKER.
Xploding-TDi
Cadet
Posts: 62
Joined: Sun Feb 23, 2014 5:43 pm
Location: South Africa

Re: Help Please - Steering,ABS and handbrake light and warni

Post by Xploding-TDi » Fri Nov 28, 2014 6:40 pm

So results from vw today:
No faults where found -
Tech guy cleaned all grounding cables and alternator cables as well.

He seems to be happy that the engine side is good.

The reason why all the warnings comes on is the system picks up low voltage and shuts down all electronics to save power.

So going to drive it now, and will see if it happens again.
johann louw
Enlisted
Posts: 4
Joined: Sat Feb 20, 2016 9:11 am
Car Make: vw
Car Model: 1.9 tdi
Location: sout africa

Re: Help Please - ABS and handbrake warning light

Post by johann louw » Sat Feb 20, 2016 11:31 am

Hi guys, i have a polo 1.9 tdi of which the abs and handbrake warning light sometimes comes on while im driving and sometimes straight from start up then it will stay on for a few minutes or even more than a day. i replaced my front left wheel bearing about three months ago. i have checked my battery cables as well as the earth cables and the problem just keeps on coming back.

Sometimes after being away from my car while it was locked (central locking) the cluster lost power as nothing appears on it like the clock or the kilometer reading. even the central locking doesn't work. i have to unlock it manually with the key in the door lock.
When i start to turn the key to the "on" mode still nothing appears. only when i turn it further so that the enjin starts running then suddenly all the lights came on as it should and everything is back to normal. Please help.
rob_hey
Enlisted
Posts: 26
Joined: Thu Feb 25, 2016 8:57 am
Car Make: VW
Car Model: 9N3 Polo 1.9TDi
Location: Stellenbosch

Re: Help Please - Steering,ABS and handbrake light and warni

Post by rob_hey » Thu Feb 25, 2016 10:05 am

Hi All

I had the same issue with the ABS and handbrake warning light coming on, the warning lights would go off after a second and there were 3 beeps.

A few months after the warning light issue started, I had the power steering light come on and I lost power steering. The radio would also cut out for a second when this happened. Switching off the engine and restarting it resolved the loss of power steering. I also noticed than when I turned the ignition to off, I would lose the radio for a couple of seconds and then it would come back on. After reading several forums post on the warning light and power steering issue, it was suggested that it was the main earth strap from the battery to the body. I checked out the strap and it looked OK. I cleaned up both sides of the connection, but the issue persisted. I went to an auto electrician who scanned my car, he got 2 errors relating to low voltage, sorry didn't make a note of the codes, though one was related to the airbag!?! He also tested the battery and alternator and all was well.

In the end I replaced the earth strap and haven't had an issue in the past month. I was getting warnings at least twice a week.

Swap out the earth strap, it's a quick, cheap job and hopefully resolves your issue.

Good luck

Rob
johann louw
Enlisted
Posts: 4
Joined: Sat Feb 20, 2016 9:11 am
Car Make: vw
Car Model: 1.9 tdi
Location: sout africa

Re: Help Please - Steering,ABS and handbrake light and warni

Post by johann louw » Thu Feb 25, 2016 10:36 am

Hi rob

Can you tell me if your car also lost all power on the cluster sometimes while it was locked or and if maybe direct after the key was removed from the ignition?
Also if you can maybe tell me at the time the electrician tested your car, did the fault occur at that actual time or did your car showed that everything was working correctly. (normally)
VW tested my car sometime ago while everything was working normally or correctly and they're computer did not find any problems.
Please let me know.
Regards, JOHANN
rob_hey
Enlisted
Posts: 26
Joined: Thu Feb 25, 2016 8:57 am
Car Make: VW
Car Model: 9N3 Polo 1.9TDi
Location: Stellenbosch

Re: Help Please - Steering,ABS and handbrake light and warni

Post by rob_hey » Thu Feb 25, 2016 10:55 am

Hi Johann

To be honest, I didn't notice the power on the cluster going, it may have been a quick loss that I didn't notice, but now that I think about it, the radio did die for a second when the warning lights came up or when I lost power steering, this may indicate a power loss in general.

With regard to the the faults the electrician found, he didn't say when they occurred, so I couldn't say whether they coincided with the warning / power steering issues. The issue didn't come up during the time he had the car.

I did also take the car to VW to check out when the issue first started. I explained the issue and suggested they check out the earth strap. They didn't find any fault codes and I don't think they checked the strap, as the issue persisted after I got the car back. They said they cleaned the main fuses.

With regard to the power loss I noted in my post relating to the ignition. The power loss (radio dying) happened when I turned the ignition to the off position, not when I removed the key. Basically, I'd turn the ignition off and as it hit the off position (without the key being removed) the radio dies for a second and then came back on. I didn't check to see whether the cluster lost power as well.

I'm 90% sure your issue is the earth strap, it's already been mentioned in this thread and I've read of this being the solution in many other forums.

Cheers

Rob
johann louw
Enlisted
Posts: 4
Joined: Sat Feb 20, 2016 9:11 am
Car Make: vw
Car Model: 1.9 tdi
Location: sout africa

Re: Help Please - Steering,ABS and handbrake light and warni

Post by johann louw » Thu Feb 25, 2016 3:10 pm

Thanks Rob

I've bought a earth strap and will replace it. Will test it for a few days.
rob_hey
Enlisted
Posts: 26
Joined: Thu Feb 25, 2016 8:57 am
Car Make: VW
Car Model: 9N3 Polo 1.9TDi
Location: Stellenbosch

Re: Help Please - Steering,ABS and handbrake light and warni

Post by rob_hey » Fri Feb 26, 2016 9:24 am

Cool, hope this fixes your issue.

Make sure to clean up the battery terminal and the connection point on the body before you connect up the new strap.
Korn
Enlisted
Posts: 1
Joined: Tue Apr 10, 2018 1:03 pm

Advise please - Steering,ABS, handbrake light and no speedo

Post by Korn » Thu Apr 12, 2018 8:48 pm

Hi

I have exactly the same problem with a Golf GT 2.0 Fsi Automatic. The difference is that the ECU was replaced and remapped not to long ago and the the car was not in use for probably 6 - 7 months. So after replacing the ECU we start the car and then this U0121 error came up with ABS, Power Steering,flashing hand brake light and no speedo. I checked all the fuses and battery and they look all good and enough power.

When we replaced the the ECU we took it for a test drive and it didn't shift gears on auto or with manual selection, this was when I saw the speedometer is not working. It also kind of jumped into drive/reverse when selecting them. but after replacing transmission oil it seemed to sort that out. It also don't go pass 3000rpm but we think the code P0191 which relate to fuel pressure might have to do with it or the car is in limb mode due to ABS problem.

Do you think this ABS control module damaged together with the ECU? It just seem strange that the car never had this problem according the owner so I cant help thinking that as soon as this car pick up speed on the speedometer it will actually sort it self out. Maybe the reason why its not shifting gears? Lol that's my wishful thinking. Can you please give some advise so that I can at least make 100% sure its not something else before I replace that ABS module.

Unfortunately we only have a OBD2 reader and this is the codes we get on the car while idling

U0121
P0191 (can clear but comes back after while)
P0606 (can clear but comes back after while)

Golf GT 2.0 Fsi 2004 imported
Automatic not the DSG gearbox
Post Reply