2017 VIVO GTS STRANGE RADIO BUG

This forum is designated for In Car Entertainment discussion...
Forum rules
Please take a look at the rules for posting in the Technical section as all posts will be moderated accordingly...

Technical Section Rules
Post Reply
Polow27
Enlisted
Posts: 15
Joined: Fri Feb 23, 2018 11:11 am

2017 VIVO GTS STRANGE RADIO BUG

Post by Polow27 »

Good day All,

I'm looking for some advice regarding a issue with my OEM double din radio in my 2017 VIVO GTS please.

4 days ago upon entering the car the radio was on and indicated the "1000" whereby it requires the code to take it out of safe mode, I started the car and the radio unlocked by itself and started working normally and did not require the code anymore. The problem of the radio going on by itself hasn't occurred again but now every time the car stands for roughly a hour or more then you turn the radio on with the ignition off it says "Safe" followed by requiring the unlock code but the minute you start the car the radio unlocks and works perfectly. I took the car to VW the Glen and booked it in but the morning of needing to drop the car off the radio worked perfectly with the ignition off and on but I proceeded to take the car to the dealership anyway but they said they couldn't do anything as it wasn't requesting the code anymore. further to this I haven't interfered with the electronics or sound system of the vehicle in anyway and everything is OEM in the car, also the car doesn't have any issues starting so the dealership and I have ruled out the possibility of the battery being an issue and lastly these cars didn't come with the code in the service book to unlock the radio. Can anybody give me some advise as to what could be the cause of this strange bug with the radio, what I could or who I could take it to in the JNB area to get sorted?

I'd appreciate any helpful feedback please.
Howie-WP
VWCSA Member
Posts: 14022
Joined: Mon Jul 29, 2002 11:45 am
Membership No: 2033
Location: Cape Town, SA

Re: 2017 VIVO GTS STRANGE RADIO BUG

Post by Howie-WP »

Your dealer should have supplied radio unlock code (if there is one) Get it.

Have you checked battery grounding? also could be a wire loom connection issue, plug could be loose and it thinks it has been "unplugged" I'd check the wiring.... What happens if you switch on radio but ignition is on? If only happens when ignition is off, it is power related?
Polow27
Enlisted
Posts: 15
Joined: Fri Feb 23, 2018 11:11 am

Re: 2017 VIVO GTS STRANGE RADIO BUG

Post by Polow27 »

Hi Howie-WP,

Thank you for your response. Yes the "Safe" mode only occurs when the car has been parked for more than an hour and I put the radio on with the ignition off but should I put the ignition on first then put the radio on it doesn't show the "Safe" mode or ask for the code.

Are you referring to the plug and wiring at the back of the radio that I should check?

I will have a look at my battery grounding today.
Post Reply